Microsoft Skript-Editor

Sie können im Microsoft® Skript-Editor HTML-Tags in HTML-Dateien und Active Server Page-Dateien (.asp) anzeigen und bearbeiten. Sie können Ihren Dateien auch ein Skript wie beispielsweise Microsoft Visual Basic®, Scripting Edition (VBScript) oder JScript® hinzufügen und das Skript debuggen.

Vorsicht Nachdem Sie einer ASP-Datei ein Serverscript hinzugefügt haben, öffnen und speichern Sie die Datei nicht in Office, sondern in Microsoft Skript-Editor. Wenn Sie nämlich eine ASP-Datei mit einem Serverskript in Office öffnen oder speichern, werden einige HTML-Tags in der Datei geändert.

In der Quellcodeansicht wird die Textfarbe in einer Datei entsprechend der Textfunktionalität angezeigt. HTML-Tags werden beispielsweise braun, Tagattribute rot und Attributwerte blau angezeigt. Sie können in der Vorschau die Seite im Layout des Webbrowsers anzeigen.

Weitere Informationen hierzu finden Sie im Inhaltsverzeichnis unter Tasks im HTML-Editor.

Vorsicht Bearbeiten Sie im Microsoft Skript-Editor nur HTM- oder ASP-Dateien. Wenn Sie andere Dateien (beispielsweise DOC-Dateien) im Microsoft Skript-Editor bearbeiten, werden die ID-Parameter, die Tags <SPAN> und <DIV> sowie einige VALUE-Parameter geändert, wenn Sie die Datei speichern oder aktualisieren.


Anordnen von Elementen auf Webseiten

Wenn Sie Webseiten erstellen, die mit Hilfe von Internet Explorer ab Version 4.0 DHTML angezeigt werden, können Sie die Elemente auf den Seiten nach absoluten Werten anordnen. Sie können diesen Elementen eine Position mit Hilfe von x- und y-Koordinaten zuweisen, die relativ für das Fenster gelten, in dem die Anzeige erfolgt. (Im Gegensatz hierzu erscheinen Elemente, die nicht absolut positioniert sind, auf der Seite jeweils ausgerichtet am sie umgebenden HTML-Text.) Da absolut positionierte Elemente an jeder beliebigen Stelle einer Seite angeordnet werden können, ergibt sich auch die Möglichkeit, diese in mehreren Ebenen anzuordnen.

Anmerkung Die absolute Positionierung wird in Versionen von HTML vor 4.0 nicht unterstützt. Falls die Seiten Ihrer Anwendung in zahlreichen verschiedenen Browsern angezeigt werden, sollten Sie die Anordnung der Elemente stattdessen mit Hilfe von Absatzausrichtung und Tabellen vornehmen.

Container-Objekte wie Tabellen und Teilungen (sog. Divisions, DIVs) können ebenfalls absolut positioniert werden. Die Objekte in einem Container werden dann in Bezug auf den Container absolut positioniert.

Im Editor verwenden Sie die Entwurfsansicht, wenn Sie mit absolut positionierten Elementen arbeiten. In der Entwurfsansicht können Sie Elemente in absolut positionierte Elemente umwandeln und diese dann an die gewünschte Position ziehen.

Hinweis Die Entwurfsansicht ist nicht für Seiten verfügbar, die in Microsoft Office erstellt wurden. Sie können in der Quellcodeansicht HTML zwar ändern, die Entwurfsänderungen müssen jedoch in einem Microsoft Office-Programm erstellt werden. Die Entwurfsansicht ist nur für Seiten verfügbar, die im Microsoft Skript-Editor geöffnet wurden.

So positionieren Sie ein Element absolut

  1. Wechseln Sie im Editor in die Ansicht Entwurf.

  2. Markieren Sie das zu positionierende Element.

  3. Klicken Sie im Menü Format auf Absolute Positionierung. Der Editor wandelt die Elemente in absolut positionierte Elemente an der entsprechenden Position um.

  4. Um die Postion eines Elements zu ändern, ziehen Sie das Element an die gewünschte Position auf der Seite.

Die Position des Elements im HTML-Text der Seite spielt keine Rolle. In der Entwurfsansicht wird das Element an den von Ihnen festgelegten x- und y-Koordinaten angezeigt. Wenn Sie in der Entwurf-Symbolleiste auf Details anzeigen klicken, wird die Verankerung des Elements — seine Position im HTML-Text — durch das Quellcodeverwaltungssymbol (Glyph) angezeigt.

Mit Hilfe einer Teilung (<DIV>-Block) oder eines sog. Umfangs (Span) (<SPAN>-Block) können Sie mehrere Elemente zu einer Sammlung zusammenfassen, die absolut positioniert werden kann. So ist es beispielsweise möglich, mehrere Absätze und ein Bild in einer Teilung zusammenzufassen, und diesen dann absolut zu positionieren.

So fassen Sie Elemente in einer Teilung zusammen und positionieren sie absolut

  1. Wechseln Sie in die Ansicht Entwurf.

  2. Wählen Sie die zusammenzufassenden Elemente aus. Die Elemente müssen im Dokument hintereinander stehen.

  3. Klicken Sie im Menü HTML auf Teilung.

  4. Wählen Sie im Dialogfeld Teilung einfügen die Option Absolut und klicken Sie dann auf OK.

Der HTML-Editor fügt die Teilungs-Tags (<DIV> und </DIV>) um die markierten Elemente ein. Sie können nun die gesamte Teilung in der Entwurfsansicht markieren und absolut positionieren.

Anmerkung Falls Sie ein bestimmtes Element absolut positioniert haben, und dieses Element seinerseits zu einer Teilung gehört, die absolut positioniert ist, können Sie das einzelne Element durch Ziehen auch außerhalb der Grenzen der Teilung anordnen. Das Element gehört jedoch weiterhin zu der Teilung und wird mitverschoben, wenn Sie die Teilung verschieben.

Beim Zusammenfassen der Elemente in einem Umfang erstellen und markieren Sie zunächst den Umfang und klicken dann im Menü Format auf Absolute Positionierung.

Um die Positionierung der Elemente zu vereinfachen, können Sie festlegen, dass alle Elemente, die Sie in der Entwurfsansicht aus der Werkzeugsammlung ziehen, automatisch absolut positioniert werden.

So positionieren Sie Elemente beim Ziehen aus der Werkzeugsammlung automatisch absolut

  • Aktivieren Sie den Modus der absoluten Ausrichtung, indem Sie in der Entwurfs-Symbolleiste auf die Schaltfläche Absoluter Modus klicken. Nun werden alle Elemente, die Sie in der Entwurfsansicht aus der Werkzeugsammlung ziehen, automatisch positioniert.

Um eine genaue Ausrichtung der Elemente sicherzustellen, können Sie ein unsichtbares Raster aktivieren.

So richten Sie die Elemente an einem Raster aus

  • Klicken Sie in der Entwurfs-Symbolleiste auf die Schaltfläche Am Raster ausrichten. Zum Festlegen der Rasterweite klicken Sie im Menü Extras auf Optionen, wählen Sie HTML, und legen Sie dann die Rasterweite mit Hilfe der Optionen unter Raster fest.

    Anmerkung Änderungen, die Sie an den Rastereinstellungen vornehmen, wirken sich erst aus, wenn Sie das nächste Mal das Dokument öffnen.

    Um zu verhindern, dass ein absolut positioniertes Element unbeabsichtigt verschoben wird, können Sie das Element an der Position sperren. Wenn ein Element gesperrt ist, können Sie es nur mit der Tastenkombination UMSCH+PFEILTASTE verschieben.

So sperren Sie ein Element an einer bestimmten Position

  • Markieren Sie das Objekt und klicken Sie dann in der Entwurfs-Symbolleiste auf die Schaltfläche Sperren.

    Absolut positionierte Elemente sind in mehreren Ebenen angeordnet, können sich also überlappen. Die Ebene eines Elements wird durch dessen Format-Attribute Z-Reihenfolge bestimmt. HTML-Elemente, die nicht absolut positioniert sind, befinden sich in Ebene Null. Elemente mit positiven Z-Reihenfolge-Werten befinden sich vor diesen Elementen. Je niedriger der Wert, desto weiter vorne befindet sich das Element. Elemente mit negativen Z-Reihenfolge-Werten befinden sich hinter den Elementen auf der Seite, die nicht absolut positioniert sind.

So ändern Sie die Ebene eines Elements

  • Markieren Sie das Element, klicken Sie im Menü Format auf Reihenfolge und wählen Sie eine der Optionen in der folgenden Tabelle, um das Element nach vorne oder nach hinten zu verschieben:
    Option | Aktion
    In den Vordergrund | Bringt das Element vor alle anderen Elemente im gleichen Container. Falls das Element einen negativen Z-Reihenfolge-Wert hat, wird ihm der negative Z-Reihenfolge-Wert zugewiesen, der am nächsten an Null liegt.
    In den Hintergrund | Bringt das Element hinter alle anderen Elemente im gleichen Container. Falls das Element einen negativen Z-Reihenfolge-Wert hat, wird ihm der negative Z-Reihenfolge-Wert zugewiesen, der am weitesten von Null liegt.
    Ebene nach vorne | Bringt das Element vor das Element mit dem nächsten Z-Reihenfolge-Wert im gleichen Container.
    Ebene nach hinten | Bringt das Element hinter das Element mit dem nächsten Z-Reihenfolge-Wert im gleichen Container.
    Hinter den Text | Ändert den Z-Reihenfolge-Wert des Elements in einen negativen Wert, so dass es sich hinter dem Text auf der Seite befindet. (Steht nur in Entwurfsansicht zur Verfügung.)
    Vor den Text | Ändert den Z-Reihenfolge-Wert des Elements in einen positiven Wert, so dass es sich vor dem Text auf der Seite befindet. (Steht nur in Entwurfsansicht zur Verfügung.)

    – Oder -

  • Markieren Sie das Element und legen Sie dann im Dialogfeld Eigenschaften den Z-Reihenfolge-Wert fest (das Format-Attribut .zIndex). Die Z-Reihenfolge-Werte anderer absolut positionierter Elemente auf der Seite wird automatisch angepasst. Wenn Sie einen negativen Z-Reihenfolge-Wert festlegen, wird das absolut positionierte Element hinter der HTML-Seite angezeigt.


Einfügen von Laufschrift auf Webseiten

Mit Hilfe eines Laufschrift-Steuerelements können Sie Laufschrift auf einer Seite verwenden. Dabei wird der festgelegte Text wie bei einem Ticker über die Seite bewegt.

Hinweis Die Entwurfsansicht ist nicht für Seiten verfügbar, die in Microsoft Office erstellt wurden. Sie können in der Quellcodeansicht HTML zwar ändern, die Entwurfsänderungen müssen jedoch in einem Microsoft Office-Programm erstellt werden. Die Entwurfsansicht ist nur für Seiten verfügbar, die im Microsoft Skript-Editor geöffnet wurden.

So fügen Sie Laufschrift ein

  1. Markieren Sie in der Entwurfsansicht oder in der Quellcodeansicht den Text, der als Laufschrift erscheinen soll.

    Der Text muss sich nicht unbedingt in einem eigenen Absatz befinden. Bei der Anzeige im Browserfenster befindet sich der Text stets in einer eigenen Zeile.

  2. Klicken Sie im Menü HTML auf Laufschrift.

  3. Markieren Sie den Laufschrift-Text und legen Sie dann im Fenster Eigenschaften folgende Eigenschaften fest, um zu bestimmen, wie der Textlauf erfolgt:
    Eigenschaft Einstellungen
    behavior

            SCROLL: Text läuft von einem Rand auf die Seite und am anderen Rand wieder heraus
    SLIDE: Text bleibt am gegenüberliegenden Rand stehen
    ALTERNATE: Text bewegt sich zwischen den Rändern hin und her

    direction

            LEFT oder RIGHT, legt fest, wo die Laufschrift beginnen soll

    loop

            Legt fest, wie oft die Laufschrift wiederholt werden soll. Bei der Einstellung -1 erfolgt die Wiederholung unbegrenzt

    scrollamount

            Anzahl der Pixel, die der Text bei jeder Laufbewegung versetzt wird. Je geringer diese Einstellung, desto gleichmäßiger bewegt sich der Text, wobei gleichzeitig die Geschwindigkeit sinkt.

    scrolldelay

            Anzahl der Millisekunden, die zwischen jeder Laufbewegung vergeht. Je niedriger diese Zahl desto schneller bewegt sich der Text.

    width

            Breite des Laufbereichs in Pixel oder als Prozentsatz der Bildschirmbreite.


Einfügen von Hyperlinks und Lesezeichen in Webseiten

Ein Hyperlink ist ein bestimmter Bereich auf einer Seite, der eine Aktion auslöst, wenn ein Benutzer darauf klickt. Hyperlinks können für folgende Zwecke eingesetzt werden:

  • Sprünge an andere Stellen, wie andere Webseiten, andere Stelle auf der aktuellen Seite (Lesezeichen) oder Lesezeichen auf einer anderen Seite.

  • Starten eines E-Mail-Programms und Verfassen einer Nachricht an den angegebenen Empfänger.

  • Übertragen und Öffnen oder Ausführen eines Dokuments oder einer Datei.

  • Zugreifen auf Ressourcen im Internet unter Verwendung der Protokolle FTP, Gopher, TelNet und WAIS.

Hyperlinks können sich in einem Text, einem Bild oder einem anderen HTML-Element befinden, beispielsweise einer Laufschrift. Der Hyperlink wird in einem Browser gewöhnlich durch eine andere Farbe und/oder Unterstreichung gekennzeichnet, abhängig von den Benutzereinstellungen für den Browser.

Hinweis Die Entwurfsansicht ist nicht für Seiten verfügbar, die in Microsoft Office erstellt wurden. Sie können in der Quellcodeansicht HTML zwar ändern, die Entwurfsänderungen müssen jedoch in einem Microsoft Office-Programm erstellt werden. Die Entwurfsansicht ist nur für Seiten verfügbar, die im Microsoft Skript-Editor geöffnet wurden.

So fügen Sie einen Hyperlink ein

  1. Markieren Sie in der Entwurfsansicht oder in der Quellcodeansicht den Text, das Bild oder das sonstige Element, das als Hyperlink fungieren soll.

    Anmerkung Sie können kein Element markieren, das bereits Teil eines Hyperlinks oder eines Lesezeichens ist.

  2. Klicken Sie im Menü HTML auf Hyperlink.

  3. Wählen Sie im Dialogfeld Hyperlink das zu verwendende Protokoll aus der Liste unter Typ, wie in der folgenden Tabelle beschrieben.
    Für einen Hyperlink zum | Wählen Sie das Protokoll
    Springen auf eine andere Webseite | http:
    Springen an ein Lesezeichen auf der aktuellen Seite | Keine Protokolleinstellung (sonst.).
    Herunterladenund Öffnen einer Datei | file:
    Versenden von E-Mail | mailto:
    Zugreifen auf andere Ressourcen im Internet | das für die jeweilige Ressource benötigt wird (beispielsweise ftp).

  4. Geben Sie in das Feld URL das Ziel des Hyperlink-Typs an, wie in der folgenden Tabelle beschrieben.
    Erstellen eines Hyperlinks zum | Eingabe im Feld URL
    Springen auf eine andere Webseite | Der URL der Seite, zu der der Sprung führt.
    Springen an ein Lesezeichen auf der aktuellen Seite | Hash-Zeichen (#), gefolgt von dem Namen des Lesezeichens (beispielsweise #teil2).
    Springen zu einem Lesezeichen auf einer anderen Seite | Der URL der Zielseite, gefolgt von einem Hash-Zeichen (#) und dem Namen des Lesezeichens, zu dem Sie springen möchten (beispielsweise meineseite.htm#teil2).
    Herunterladen und Öffnen einer Datei | Pfad oder URL der Datei.
    Senden von E-Mail | Die vollständige E-Mail-Adresse des Empfängers (beispielsweise anne@mycompany.com)

    Tipp Sie können eine QuickInfo für einen Hyperlink festlegen, indem Sie diesen im Eigenschaftenfenster als Eigenschaft Title für den Hyperlink eingeben.

Lesezeichen können an jeder beliebigen Stelle einer Seite eingefügt werden.

So fügen Sie ein Lesezeichen ein

  1. Bewegen Sie den Mauszeiger in der Entwurfsansicht oder der Quellcodeansicht auf die Stelle, an der das Lesezeichen eingefügt werden soll. Sie können optional einen Textbereich markieren, der dann als Name für das Lesezeichen fungiert.

  2. Klicken Sie im Menü HTML auf Lesezeichen.

  3. Geben Sie im Dialogfeld Lesezeichen den gewünschten Namen für das Lesezeichen ein.


Erstellen von Teilungen und Umfängen in einem HTML-Dokument

Der HTML-Editor bietet eine einfache Möglichkeit zum Einfügen von Teilungen und Umfängen in HTML-Dokumenten. Teilungen sind Bereiche eines Dokuments, mit deren Hilfe Sie eine Sammlung von Elementen definieren können, denen dann Attribute zugewiesen werden. Ein Umfang entspricht weitgehend einer Teilung, wobei eine Teilung stets vom Rest des Dokuments als eigener Absatz getrennt ist, während ein Umfang auch aus Absatzteilen gebildet werden kann. Sowohl für Teilungen als auch für Umfänge gilt, dass die einzuschließenden Elemente im Dokument aufeinander folgen müssen.

Mit Hilfe von Teilungen und Umfängen können Sie folgende Attribute für Sammlungen von Elementen festlegen:

  • Stil-Informationen Sie können eine Teilung definieren und dann gleichzeitig allen Elementen in der Teilung bestimmte Format-Informationen zuweisen, einschließlich Stylesheet-Klasse oder Format-Attribut. Wenn Sie beispielsweise die Absatzausrichtung oder die Schriftart der Teilung ändern, wirkt sich diese Einstellung auf alle Absätze in der Teilung aus.

  • Absolute Positionierung Wenn Sie mit einem Browser arbeiten, der DHMTL (Dynamic HTML) unterstützt, können Sie eine Teilung definieren und dann eine absolute Positionierung dafür angeben. Danach können alle Elemente in der Teilung gemeinsam positioniert werden, indem Sie einfach die Teilung verschieben.

Teilungen werden im HTML-Dokument durch die Tags <DIV> und </DIV> angezeigt. Alle HTML-Elemente zwischen diesen beiden Tags gehören zu der Teilung. Umfänge werden in die Tags <SPAN> und </SPAN> eingeschlossen.

Hinweis Die Entwurfsansicht ist nicht für Seiten verfügbar, die in Microsoft Office erstellt wurden. Sie können in der Quellcodeansicht HTML zwar ändern, die Entwurfsänderungen müssen jedoch in einem Microsoft Office-Programm erstellt werden. Die Entwurfsansicht ist nur für Seiten verfügbar, die im Microsoft Skript-Editor geöffnet wurden.

So erstellen Sie eine Teilung

  1. Wechseln Sie in die Entwurfsansicht.

  2. Markieren Sie den Teil des HTML-Dokuments, der in die Teilung aufgenommen werden soll. Die Teilung kann sowohl Text als auch andere Elemente enthalten, beispielsweise Bilder und so weiter.

  3. Klicken Sie im Menü HTML auf Teilung.

  4. Wählen Sie im Dialogfeld Teilung einfügen eine Option für die Positionierung:
    • Absolut Wählen Sie diese Option, wenn die Teilung eine Sammlung von Elementen enthält, die absolut positioniert werden soll. Die absolute Positionierung ist nur in Browsern möglich, die DHTML unterstützen.

    • Inline Wählen Sie diese Option, wenn die Teilung dazu dienen soll, Formate zuzuweisen, und keine absolute Positionierung der Elemente erfolgen soll.

      Tipp Klicken Sie in der Entwurfs-Symbolleiste auf Sichtbare Rahmen, um die Arbeit mit absolut positionierten Teilungen in der Entwurfsansicht zu erleichtern.

So erstellen Sie einen Umfang

  1. Wechseln Sie in die Entwurfsansicht.

  2. Markieren Sie den Teil des HTML-Dokuments, der in den Umfang aufgenommen werden soll. Der Umfang kann sowohl Text als auch andere Elemente enthalten, beispielsweise Bilder und so weiter.

  3. Klicken Sie im Menü HTML auf Umfang.

    Tipp Klicken Sie in der Entwurfs-Symbolleiste auf Sichtbare Rahmen, um die Arbeit mit Umfängen in der Entwurfsansicht zu erleichtern.

Nachdem Sie eine Teilung oder einen Umfang definiert haben, können Sie Elemente hinzufügen.

So fügen Sie Elemente zu einer Teilung oder einem Umfang hinzu

  • Markieren Sie in der Entwurfsansicht die Teilung oder den Umfang, plazieren Sie die Einfügemarke innerhalb der Teilung und fügen Sie dann das/die gewünschte(n) Element(e) ein.


Erstellen von Skripts im HTML-Editor

Der HTML-Editor enthält zahlreiche Features, die bei der Erstellung von Skripts hilfreich sind. Sie können Ereignisbehandlungsroutinen für Elemente auf Seiten erstellen, bei denen es sich um Skripts handelt, die als Reaktion auf bestimmte Aktionen ausgeführt werden, beispielsweise wenn ein Benutzer auf eine Schaltfläche klickt, oder wenn ein Dokument erstmalig geladen wird, oder wenn ein anderes Ereignis eintritt. Mit den Features des Editors können Sie außerdem eigenständige Skriptblöcke erstellen, die beliebige Skriptelemente enthalten und nicht auf Ereignisbehandlungsroutinen beschränkt sind.

Tipp Wenn Sie Skriptelemente in den Hauptteil eines Dokuments (Body) eingeben, sollten Sie in der Entwurfs-Symbolleiste auf Details anzeigen klicken. Dann wird in der Entwurfsansicht ein Quellcodeverwaltungssymbol (Glyph) für das Skript angezeigt. Ohne dieses Symbol würde das Skript in der Entwurfsansicht nicht angezeigt, so dass Sie es versehentlich löschen könnten.

Zum Erstellen von Ereignisbehandlungsroutinen verwenden Sie das Skriptgliederungsfenster. Im Skriptgliederungsfenster werden alle skriptfähigen Elemente der Seite angezeigt. Zu jedem Element werden die Ereignisse aufgeführt, für die Behandlungsroutinen geschrieben werden können. Im Skriptgliederungsfenster werden die Elemente und Skripts, die auf dem Client ausgeführt werden, von denen getrennt aufgeführt, die auf dem Server ausgeführt werden.

Im Editor schreiben Sie die Skripts in der Quellcodeansicht. Auch wenn Sie in der Entwurfsansicht arbeiten, können Sie jederzeit mit der Eingabe von Skriptelementen für die Elemente beginnen, die Sie bearbeiten.

Hinweis Die Entwurfsansicht ist nicht für Seiten verfügbar, die in Microsoft Office erstellt wurden. Sie können in der Quellcodeansicht HTML zwar ändern, die Entwurfsänderungen müssen jedoch in einem Microsoft Office-Programm erstellt werden. Die Entwurfsansicht ist nur für Seiten verfügbar, die im Microsoft Skript-Editor geöffnet wurden.

So beginnen Sie die Eingabe von Skriptelementen in der Entwurfsansicht

  • Doppelklicken Sie auf das Element, für das Sie eine Ereignisbehandlungsroutine schreiben möchten, oder klicken Sie mit der rechten Maustaste auf das Element, und klicken Sie dann auf Skript bearbeiten.

    Der Editor wechselt in die Quellcodeansicht. Außerdem wird das Skriptgliederungsfenster angezeigt und der Fokus wird auf die Standardbehandlungsroutine für das jeweilige Element gesetzt. Falls das angeklickte Element noch nicht über ein ID-Attribut verfügt, wird dieses vom HTML-Editor automatisch hinzugefügt.

Wenn das Skriptgliederungsfenster angezeigt wird, können Sie für jedes Element auf der Seite ein Grundgerüst für eine Ereignisbehandlungsroutine erstellen.

So erstellen Sie eine Ereignisbehandlungsroutine

  1. Erweitern Sie im Skriptgliederungsfenster den Knoten des Elementes, für das Sie eine Ereignisbehandlungsroutine schreiben möchten.

  2. Doppelklicken Sie auf das Ereignis, für das ein Skript erstellt werden soll.

Wenn Sie auf den Namen eines Ereignisses doppelklicken, führt der Editor folgende Aktionen aus:

  • Erstellung oder Sprung zu einem der folgenden Skriptblöcke am Anfang des Dokuments, abhängig davon, wo das Skript ausgeführt wird und in welcher Sprache es erstellt wird:
    • clientEventHandlersJS

    • clientEventHandlersVBS

    • serverEventHandlersJS

    • serverEventHandlersVBS
  • Einfügen einer neuen, leeren Ereignisbehandlungsprozedur für das angegebene Element und Ereignis.

  • Hinzufügen eines Ereignisattributs (beispielsweise onclick=), falls das Skript in JavaScript erstellt wird.

  • Positionierung der Einfügemarke in der zweiten Zeile des neuen Skripts, so dass Sie sofort die gewünschten Befehle eingeben können.

Die Sprache, die für das Grundgerüst einer Ereignisbehandlungsroutine verwendet wird, hängt von der Standardsprache für Client- oder Serverskripts ab, wie im Dialogfeld Eigenschaften für das aktuelle Dokument festgelegt. Für VBScript-Funktionen lautet das Format:

Sub elementID_event

End Sub

Für JavaScript-Funktionen lautet das Format:

function elementID_event(){

}

Beim Erstellen von Ereignisbehandlungsroutinen in JavaScript fügt der Editor zusätzlich folgende Attribute für das HTML-Element selbst ein:

event="return elementID_event()"

Neben der Erstellung von Ereignisbehandlungsroutinen ist es auch möglich, eigenständige Skriptblöcke zu erstellen. Dies ist insbesondere sinnvoll, wenn Sie bestimmte Prozeduren (Subroutinen oder Funktionen) erstellen möchten, die von anderen Skripts aufgerufen werden können, oder wenn Sie globale Skriptteile entwickeln, die sofort ausgeführt werden, wenn die Seite vom Browser verarbeitet wird.

So erstellen Sie einen eigenständigen Skriptblock

  1. Wechseln Sie in die Quellcodeansicht.

  2. Bewegen Sie sich zu der Stelle im Dokument, an der das Skript angezeigt werden soll.

  3. Klicken Sie im Menü HTML auf Skriptblock und wählen Sie dann Client oder Server.

    Der HTML-Editor legt einen <SCRIPT>-Block an. Falls Sie Server gewählt haben, enthält das Skript-Tag das Attribut RUNAT=SERVER. Das Attribut LANGUAGE des Skriptblocks wird auf die Standardsprache des Clients oder des Servers eingestellt.


Zuweisen von Formaten zu HTML-Text

Neben der Möglichkeit, einzelne Zeichen oder Abschnitte in HTML-Dokumenten zu formatieren, besteht auch die Möglichkeit, Formate oder vordefinierte Format-Anweisungen zuzuweisen.

Im HTML-Editor können Sie mit Hilfe folgender Techniken Formate definieren und zuweisen:

  • Verweis auf ein Cascading Stylesheet (CSS). Diese Technik empfiehlt sich, wenn Sie die gleichen Formate in mehreren Dokumenten nutzen möchten.

  • Erstellen eines dokumentspezifischen Formatblocks. Dies entspricht weitgehend der Nutzung eines Stylesheet, wobei sich allerdings die Formatdefinitionen nur auf das aktuelle Dokument beziehen.

  • Individuelles Zuweisen von Formaten zu Elementen, wie z.B Absätzen, oder zu Sammlungen von Elementen in Teilungen oder Umfängen.

Definieren von Formaten

Sie können Formate definieren, indem Sie auf ein bestehendes Cascading Stylesheet (CSS) verweisen.

So fügen Sie einen Verweis auf ein Cascading Stylesheet ein

  1. Erstellen Sie das gewünschte Stylesheet und fügen Sie es dem aktuellen Projekt hinzu, falls es noch nicht existiert.

  2. Wechseln Sie in die Quellcodeansicht.

  3. Ziehen Sie das zu verwendende Stylesheet vom Projekt-Explorer in den Header-Teil des Dokuments (zwischen die Tags <HEAD> und </HEAD>.)

    Anmerkung Verweise auf Stylesheets müssen im Header angezeigt werden, da sie andernfalls nicht funktionieren.

Sie können auch dokumentspezifische Formatblöcke erstellen, in denen die Formate definiert werden, die im Dokument verwendet werden sollen. Hierfür müssen Sie mit der Syntax von Formatdefinitionen vertraut sein.

So erstellen Sie einen dokumentspezifischen Formatblock

  1. Wechseln Sie in die Quellcodeansicht.

  2. Erstellen Sie im Header des Dokuments (also zwischen den Tags <HEAD> und </HEAD>) einen Formatblock, der mit dem Tag <STYLE> beginnt und mit dem Tag </STYLE> endet.

  3. Geben Sie innerhalb des Formatblocks die gewünschten Format-Informationen unter Verwendung der folgenden Syntax ein:
    tag={style1: attribute;style2: attribute;...;}

    - Oder -

    tag.classname={style1: attribute;style2: attribute;...;}

    Die erste Syntax dient zum Zuweisen von Format-Attributen für alle Instanzen eines bestimmten HTML-Tags. Die zweite Syntax dient zum Definieren von Klassen, was bei der Zuweisung von Format-Attributen für beliebige Textabschnitte sinnvoll ist.

    Ein einfacher Formatblock sieht beispielsweise wie folgt aus:

    <STYLE>
H1={font-size: 14pt; font-weight: bold; font-family: sans-serif;)
P={font-size; 11pt; font-weight: bold; color: blue;)
SPAN.ProductName={font-weight: bold; color: red;}
</STYLE>

    Tipp Eine einfache Möglichkeit zum Erstellen der Format-Definitionen im Formatblock besteht in der Verwendung des CSS-Editors, in dem die Formate erstellt und dann aus der Quellcodeansicht dieses Editors in die aktuelle Seite kopiert werden können.

Zuweisen von Formaten

Es bestehen mehrere Möglichkeiten zum Zuweisen von Formaten:

  • Implizit. Wenn Sie auf ein Stylesheet verwiesen haben oder einen Formatblock in das Dokument eingefügt haben, werden Formate, die mit bestehenden Tags im Dokument übereinstimmen, automatisch zugewiesen. Falls beispielsweise das Stylesheet oder der Formatblock den Stil H2 als 14 Punkt, fett und serifenlos beschreibt, werden alle Absätze, die mit dem Tag H2 bezeichnet sind, entsprechend dieser Attribute formatiert (es sei denn, Sie legen ausdrücklich andere Attribute fest).

  • Durch Zuweisen einer Formatklasse zu einem individuellen Element, einem Umfang oder einer Teilung. Das Stylesheet oder der Formatblock muss in diesem Fall Klassendefinitionen enthalten. Ein Umfang unterscheidet sich von einer Teilung dadurch, dass die Teilung stets vom restlichen Teil des Dokument als eigenständiger Absatz getrennt ist.

  • Durch Festlegen von Inline-Format-Eigenschaften für jedes beliebige HTML-Element. Bei dieser Methode wird nicht auf ein bestimmtes Stylesheet oder einen Formatblock verwiesen. Falls das Format des Elements bereits in einem Stylesheet oder einem Formatblock festgelegt ist, werden diese Festlegungen durch die eingebetteten Format-Attribute übergangen.

So weisen Sie einem Element, einem Umfang oder einer Teilung eine Formatklasse oder ein Format zu

  1. Wechseln Sie in die Entwurfsansicht und markieren Sie das Element, den Umfang oder die Teilung, dem bzw. der ein Format zugewiesen werden soll.

    Hinweis Die Entwurfsansicht ist nicht für Seiten verfügbar, die in Microsoft Office erstellt wurden. Sie können in der Quellcodeansicht HTML zwar ändern, die Entwurfsänderungen müssen jedoch in einem Microsoft Office-Programm erstellt werden. Die Entwurfsansicht ist nur für Seiten verfügbar, die im Microsoft Skript-Editor geöffnet wurden.

  2. Zeigen Sie das Eigenschaftenfenster an, falls es noch nicht sichtbar ist, indem Sie im Menü Ansicht auf Eigenschaften klicken. Achten Sie darauf, dass das Element, dem ein Format zugewiesen werden soll, im Drop-down-Feld am oberen Rand des Eigenschaftenfensters markiert ist.

    Anmerkung Im Eigenschaftenfenster werden keine Format-Eigenschaften angezeigt, wenn Sie sich in der Quellcodeansicht befinden.

  3. Zum Zuweisen einer Formatklasse geben Sie den Namen der Klasse in das Feld Klasse ein. Zum Festlegen eines Inline-Formats geben Sie den Wert für dieses Format ein.

    Tipp Format-Attribute beginnen mit einem Punkt (beispielsweise .fontSize).


Speichern von HTML-Elementen

Sie können die Werkzeugsammlung nutzen, um beliebige Elemente aus einem HTML-Dokument zur späteren Wiederverwendung zu speichern — Text, Bilder, Objekte usw. Die Elemente, die Sie in der Werkzeugsammlung speichern, verbleiben dort, bis Sie sie wieder entfernen. Somit können diese Elemente im gleichen Dokument oder auch in anderen Dokumenten wieder verwendet werden.

So speichern Sie Elemente in der Werkzeugsammlung

  1. Klicken Sie in der Werkzeugsammlung auf die Registerkarte, auf der die Elemente gespeichert werden sollen (oder erstellen sie eine neue Registerkarte).

  2. Markieren Sie im HTML-Editor das Element oder die Elemente, die gespeichert werden sollen.

  3. Ziehen Sie die Markierung in die Werkzeugsammlung.

    Wenn Sie das Element ablegen, wird in der Werkzeugsammlung ein neuer Eintrag mit der Bezeichnung HTML-Ausschnitt erstellt. Um die Bezeichnung des Eintrags zu ändern, klicken Sie mit der rechten Maustaste darauf und klicken Sie dann auf Element umbenennen.

Wenn Sie ein Element in der Werkzeugsammlung speichern, legt der Editor eine exakte Kopie des HTML-Textes aus dem Dokument an. Wenn Sie dieses Element später aus der Werkzeugsammlung an eine andere Stelle im Dokument ziehen, kann es erforderlich sein, den erstellten Text anzupassen.


Erweitern der Funktionalität des HTML-Editors

Der HTML-Editor kann durch den Einsatz von Add-in-Assistenten erweitert werden. Diese Assistenten, die von Microsoft und Drittherstellern erhältlich sind, bieten einfach zu nutzende Schnittstellen für solche Aufgaben, die nicht bereits in den HTML-Editor integriert sind. So kann ein Add-in-Assistent Sie durch die Schritte führen, die beim Einfügen von Multimedia-Effekten auf einer Seite benötigt werden. Ein weiterer Add-in-Assistent könnte eine Rechtschreibprüfung im Dokument durchführen.

Die im Einzelfall nutzbaren Add-in-Assistenten sind von der jeweiligen Installation abhängig. Genauere Informationen zur Installation von HTML-Assistenten finden Sie in der Dokumentation, die dem Assistenten beiliegt.


Thema nicht gefunden

Es wurde kein entsprechendes Thema gefunden. Mögliche Ursachen und Problemlösungen hierfür sind z. B.:

  • Die Datei (.chm), die das Zielthema enthält, befindet sich nicht in dem erwarteten Verzeichnis.

    Problemlösung: Starten Sie erneut das Setup von MSDN Library.

  • Die Datei (.chm), die das aktuelle oder das Zielthema enthält, ist veraltet und die Verknüpfung ist nicht mehr gültig.

    Problemlösung: Installieren Sie die neueste Version von MSDN Library.

  • Die MSDN Library-CD befindet sich nicht im CD-ROM-Laufwerk.

    Problemlösung: Legen Sie die MSDN Library-CD in das CD-ROM-Laufwerk.


Erstellen und Bearbeiten von Tabellen im HTML-Editor

Im HTML-Editor stehen Werkzeuge zur Verfügung, mit denen das Erstellen und Bearbeiten von Tabellen auf HTML-Seiten sehr vereinfacht wird.

Hinweis Die Entwurfsansicht ist nicht für Seiten verfügbar, die in Microsoft Office erstellt wurden. Sie können in der Quellcodeansicht HTML zwar ändern, die Entwurfsänderungen müssen jedoch in einem Microsoft Office-Programm erstellt werden. Die Entwurfsansicht ist nur für Seiten verfügbar, die im Microsoft Skript-Editor geöffnet wurden.

So erstellen Sie eine Tabelle

  1. Klicken Sie im Menü Tabelle auf Tabelle einfügen.

  2. Legen Sie im Dialogfeld Tabelle einfügen die Anzahl der Zeilen und Spalten fest, die die Tabelle enthalten soll.

  3. Legen Sie die weiteren gewünschten Attribute der Tabelle fest und klicken Sie auf OK.

    Tipp Falls die Tabelle keinen Rand hat, können Sie die Bearbeitung in der Entwurfsansicht vereinfachen, indem Sie in der Entwurfs-Symbolleiste auf Sichtbare Rahmen klicken.

In Browsern werden Tabellenzellen, die keinen Text enthalten, nicht angezeigt. Deshalb werden Zellen ohne Inhalt nicht angezeigt, wenn Sie sich die Seite über Vorschau oder in einem Browser ansehen.

So bearbeiten Sie den Inhalt von Zellen

  • Setzen Sie die Einfügemarke in die Zelle und geben Sie Text ein. Sie können die Einfügemarke auch auf eine ausgeblendete Zelle setzen, aber die Einfügemarke erscheint sehr klein, bis ein Inhalt vorhanden ist.

    Anmerkung Wenn Sie die Inhalte aller Zellen in einer Zeile löschen, wird die gesamte Zeile ausgeblendet und Sie können die Einfügemarke nicht mehr auf die betroffene Zeile setzen. In der Quellcodeansicht ist jedoch weiterhin ein Bearbeiten der Tabelle möglich.

Zu bestehenden Tabellen können Zeilen, Spalten und Zellen hinzugefügt werden.

So können Sie Zeilen, Spalten und Zellen hinzufügen oder löschen

  1. Setzen Sie die Einfügemarke auf die Zeile oder Spalte, an der die Einfügung stattfinden soll.

    Anmerkung Das Setzen der Einfügemarke in eine Zelle genügt, um die Zelle, die Zeile oder die Spalte zu markieren. Sie brauchen nicht den gesamten Inhalt der Zelle, Zeile oder Spalte zu markieren.

  2. Klicken Sie im Menü Tabelle auf den entsprechenden Befehl, um das gewünschte Element hinzuzufügen. Neue Zeilen werden oberhalb der markierten Zeile eingefügt und neue Spalten bzw. Zellen links der markierten Spalte/Zelle.

Sie können Tabellenzellen auch teilen oder zusammenführen.

So teilen Sie Zellen

  1. Plazieren Sie den Cursor in der Zelle.

  2. Klicken Sie im Menü Tabelle auf Zelle teilen.

    Die aktuelle Zelle wird in zwei Zellen geteilt, die in die vorhandene Spalte passen.

So führen Sie Zellen zusammen

  1. Markieren Sie Text in den Zellen, die zusammengeführt werden sollen. Sie brauchen nicht den gesamten Text in den Zellen zu markieren. Die Zellen sind markiert, wenn mindestens ein Zeichen darin markiert ist.

  2. Klicken Sie im Menü Tabelle auf Zellen zusammenführen.

Bei einigen Operationen, beispielsweise beim Festlegen von Eigenschaften oder bei der absoluten Positionierung, muss die gesamte Tabelle markiert werden.

So markieren Sie die gesamte Tabelle

  • Bewegen Sie die Einfügemarke auf den Rand der Tabelle, bis der Mauszeiger sich in einen Verschiebecursor verwandelt, und klicken Sie dann.